Upgrading Debian from Etch to Lenny

I was trying to update my PHP and bad things started to happen:

libapache2-mod-php5: Depends: libc6 (>= 2.7-1) but 2.3.6.ds1-13etch10+b1 is to be installed
Depends: libdb4.6 but it is not installable
Depends: libkrb53 (>= 1.6.dfsg.2) but 1.4.4-7etch6 is to be installed
Depends: libssl0.9.8 (>= 0.9.8f-5) but 0.9.8c-4etch4 is to be installed
Depends: libxml2 (>= 2.6.28) but 2.6.27.dfsg-6 is to be installed
Depends: php5-common (= 5.2.13-0.dotdeb.1) but 5.2.0+dfsg-8+etch16 is to be installed.

See also

It looks like it was time to upgrade from Etch to Lenny. Here's how:

  1. Edit /etc/apt/sources.list and replace all occurrences of etch with lenny.
  2. sudo apt-get update
  3. sudo apt-get dist-upgrade

But, I also had some issues with certain keys not being allowed. This command fixed it: sudo gpg --keyserver wwwkeys.eu.pgp.net --recv-keys 9AA38DCD55BE302B

No votes yet